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Question No: 1

Ethernet Address is of----------------- bytes
> s
> 8
> 12

Question No: 2

In Pure ALOHA, the vulnerable time is ------------- the frame txahsmission time.
> Same as
~ Two times
> Three times
> Four times
Question No: 3
was used as a medium in 10 Base-T
» Thick coaxial Cable
» Think coaxial Cable

» Two Mode For Cable
Question No: 4
When data are transmitted from deyice, A«to device B, the header from A’s layer 4 is read by B’s
layer.
» transport
» application
» none of theygiven

Question No: 5

In encoding, we use three levels: positive, zero, and negative.
> (polar
» _ nonpolar
»._ mmultilevel

Question No: 6

A periodic signal completes one cycle in 0.001 s. What is the frequency?
» 1Hz
» 1KHz
> 1MHz
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Question No: 7

There are basic modes for the propagation of light in fiber-optic cables.
> 3
> 4

> 5
> 2

Question No: 8

A parabolic dish antenna is a(n) antenna.
» Omnidirectional
» Bidirectional
» Horn
> Unidirectional
Question No: 9
Zero crossing bandwidth is also called as equivalent noise bandwidth.

> True

Question No: 10
During the transmission, transmitting device produceswa high frequency signal which acts as
a basis for the transmission. This base signal is called
» Analog signal
> _ Not€onfirm
» Modulated signal
» Carrier signal
Question No 11:

There are types of serial transmission:
>
> 3
> 4

Question No12:

Synchronous transmission have
> astart bit
> ([@stopybit
» . gaps between bytes

Question No 13

Using encoding scheme in digital transmission, we represent 0 by zero voltage
level and represent 1 by any positive voltage level.

» Polar

> AMI

» Bipolar

Question No 14
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is the formula for finding number of bits sent per level.

» LogL
» Log2
» Log2*2

Question No 15
Which of the following is an example of ITU-T modem standards:?

» X-series
» N-series
» V-series
Question No 16
The maximum data rate in the uploading direction is still

» 26.6 Kbps

» 36.6 Kbps
» 46.6 Kbps
Question No 16
In each station is forced to send a frame onlysat beginning of time slot

> Pure ALOHA

> Fragmented ALOHA
» None of the given
Question 17
In each station Sends a frame whenever it has a frame to send
> Pure ALOHA
» Slotted ALOHA,
> Fragmented ALOHA

> None'ofthé given
Question No 18
The data,rate of a T-1 line is

> \1.544 Gbps
¥ 2.544 Mbps
> \.544 Kbps

Question 19
Circuit switched networks have efficiency but delay compared to the
packet switched networks.

» high, minimal
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> high, high

Question No 20
Category 5 UTP cable is used for data transmission of upto

» 200 Mbps
» 250 Mbps
» 400 Mbps
Question No 21
All of popular Fiber optic connectors are shaped.
» Conical
» Circular
» Rectangular

Question No 22

SONET stands for
» synchronous operational network
» stream optical network

» shell operational network

Question No 23
Fast Ethernet has a data rate of Mbps.
> 10

> 1000

» 10,000
Question No 24
The VLF and LF bands use propagation for communications.
» Ground
» Line of sight
» Space
Question No 25
In Bit-oriented framing, bit pattern is used as a flag to define beginning and end
ofa frame.
» (IT11111)
» %10000001)2
» Single
> (011111102
Question No 26
Traditionally, protocols have been defined for the data-link layer to deal with flow
and error control.
o Two
o Three
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o Five

Question No 27
Multiplexing is the set of techniques that allows simultaneous TX of multiple signals across
data link

» Multi
» Single and Multi
» none of the given
Question NO 28
Need for Addressing makes Asynchronous TDM inefficient for bit or byte

» Interleaving

» Substraction
» None of the given
Question No 29
takes data from one high speed line and breaks @tanto portions.

» Inverse multiplexing
» Inverse subtraction
» Inverse addition
Question No 30
For Carrier Sense Multiple Access/CollisiomDetection (CSMA/CD) we need a restriction on the

» Collision Size
» Signal Size

» Station Size
Question No 31:
In Y-MODEM Mailtiple files can be sent simultaneously

» False

Question No 32
At the data-link layer, protocol is designed to handle both flow and error control,

but communication is one frame at a time.

» Simple

» Go-Back-N

» Selective-Repeat
- Stop-and-Wait

Question No 33
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The PPP protocol uses , which is responsible for establishing,
maintaining, configuring, and terminating links.

» Internet Protocol Control Protocol (IPCP)

» Challenge Handshake Authentication Protocol (CHAP)

» Network Control Protocols (NCPs)

Question No 34

Aloha, CSMA/CD and CSMA/CA are part of
Controlled Access protocol
Channelization protocol
Mutual access protocol

Question No 35
Which of the following is an example of ITU-T modem standards:

> X-series
> N-series
> V-series

Question No 36
The maximum data rate in the uploading direction is‘still

» 26.6 Kbps

» 36.6 Kbps
» 46.6 Kbps
Question No 37
Category 5 UTP cable is usedufor datartransmission of upto

» 200 Mbps
» 250 Mbps
» 400 Mbps

QuestionNo38
ALOHA the earliest random access method was developed in early

1950s

1960s

1980s
Question No 39
In block coding, we divide our message into blocks, each of  bits; and add redundant
bits to each block to make the codewords of  bit length.

m, 1, C
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nk,r
n,r,k

Question No 40
All of popular Fiber optic connectors are shaped.
» Conical
» Circular
» Rectangular
Question No 41
MAC stand for
» Media Access Controller
» Main Access Control
» Mandatory Access Control
~ Media Access Control
Question No 42
Which one of the following is a Random-Access protocol
» CDMA/CA
» CDMA/CD
» TDMA
Question No 43
The VLF and LF bands use propagation fer cémmunications.
» Ground
» Line of sight
» Space
Question No 44
Multiplexing is the set of techniquesithat allows simultaneous TX of multiple signals across
data link
» Multi
» Single and Multi
» none ofithe\given
Question No 45
Need for Addressing makes Asynchronous TDM inefficient for bit or byte
» (Interleaving

7\, Subtraction
» None of the given
Question No 46
CDMA stands for
» Carrier Data Multiple Access

» Code Data Multiple Access
» Carrier Division Multiple Access
Question No 47
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In Ethernet, the source address field in the MAC frame is the address.
» Sender’s logical
>
» Next destination’s physical
» Sender’s service port
Question No 48
takes data from one high speed line and breaks it into portions.

» Inverse multiplexing
» Inverse subtraction
» Inverse addition
Question No 49
A traditional telephone line has a bandwidth of
» 4000 Hz
» 2000 MHz
» 4000 MHz
Question No 50
To detect five errors, the Hamming distance between each,pairof ¢odewords should be
at least

4
. 5
6

Question No 51
For FEC using XOR operation, we divideya packet into N chunks, and need to send
chunks to the receiver side.

o N

o 2N

o (N+1)2
o N+l

Question No 52
If the ASCII character H is sent and the character I is received, what type of error is this?

» “Multiple-bit
> \Burst
». Recoverable

Question No 53
At the CRC generator, added to the data unit after the division process
» Osare
» lsare
» The polynomial
> The CRC remainder is
Question No 54
Error control in the data link layer is based on
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> automatic repea request

» automatic repeat acknowledgment

» automatic send acknowledgment

Question No 55
In a technique called, compounding High-and-Low Resolution Packets, the low-
resolution section in the first packet is
»CRC  NotSure
» Parity code
» Empty
Question No 56
In line discipline the initiator first transmits a frame called an
» Enquiry
» Acknowledgment
» Reques
Question No 57
Primary device uses to receive transmigsion from the secondary devices.

> ENQ
> POLL

Question NO 58
Token Bus has no commercidhapplicatiofi in data communications

> TFalse

Question No 59

HDLC is an acronymfor .
» High-duplexline communicatio
>
>« Half-duplex digital link combination
> Host double-level circuit

Question No 59

The BNC-T connector is a T-shaped device with ports
» Three
» Four
» Five

Question No 60

Each station in the Token Ring regenerates the frame.

> False
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Question No 61

Repeater works on layer.
» Data Link
» Physical

» Application

Question No 62
Trunks are transmission media such as that handle the telephone to the nearest end

office.
» Satellite links
» Twisted-pair
» Fiber-optic

Question No 63
At the data-link layer, protocol is designed to handle bothgflow anderror control,

but communication is one frame at a time.

o Simple
o Go-Back-N
o Selective-Repeat

Question No 64
The PPP protocol uses ,which is responsible for establishing,
maintaining, configuring, and terminating\links:

» Internet Protocol Control\Pretoeol(IPCP)

» Challenge Handshake*Authentigation Protocol (CHAP)

» Network Control ProtocolSyNCPs)

Question No 65

The original Ethernett€ehnology with the data rate of 10 Mbps is called ?
>
» Fast Ethernet
» Gigabit Ethemet

> 10 Gigabit Ethernet
Question Ne 66
Normallysthe value of Kmax in pure ALOHA is
>810
> 25
> 30
Question No 67
Which one of the following is not a Channelization Protocol?

> CDMA
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» FDMA

> TDMA
Question No 68
In CSMA/CA is the amount of time divided into slots.
>
> Interframe Window
» Fragmented Window

» Collided Window
Question No 69
Aloha, CSMA/CD and CSMA/CA are part of

Controlled Access protocol
Channelization protocol
Mutual access protocol
Random Access protocol
Question No 70
ALOHA the earliest random access method was developed in garly
e 1950s
e 1960s
o 1980s
Question No 71
For FEC using XOR operation, we divide a packétinto N chunks, and need to send
chunks to the receiver side.
N
2N

(N+1)/2
N+1

Question No 71
The layer i8 responsible for the creation and delivery of a frame to another node,
along the link.

» Application

> Netwoik

» Physical

QugestiomrNoN72

[P addresses)are the identifiers at the layer.
»_ Physical
» “Data-link
» Transport

Question No 73

Each host or each interface of a router is assigned address.
» A multicast
» A broadcast
» Both multicast or broadcast
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> A umicas

Question No 74
The ARP protocol is one of the auxiliary protocols defined in the layer, which maps

an IP address to a logical-link address.

Physical
Data-link
Transport
Network
Question No 75
Following are the examples of connecting devices EXCEPT
» Link Layer Switches
» Hub
» Routers

Question No 76
eliminates collision and connect heterogeneous devices:

o Hub
o Repeater
o Bridge

Question No 77
creates looping problemyinil€arning switch.

> Unicast
> Multicast
> None of the Given

Question No 78
The term FTTC stands*for

Front Technolegy Terminal Connection
Free Technology Transmission Connection

Fiber . Terminal Transmission Commission

Question No 79
Multiple-access Protocol is divided into

Two categories
Four categories
Five categories
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Question No 80
The original Ethernet technology with the data rate of 10 Mbps is called Ethernet.

Fast
Gigabit
10 Gigabit
Question No 81
CSMA/CD is not used in Ethernet.
Standard
Fast
Gigabit
Question No 82
The amplitude of a digital signal depends upon the to representia bits
Phase
Wavelength
Bandwidth
Question No 83
In IEEE 802.11, a station with mobility can,mevefrom one BSS to another, but the
movement is confined inside one ESS.
None of the choices are correct
No-transition
ESS-transition
BSS-transition
Question No 84
In IEEE 802.11, communicatien between‘two stations in two different BSSs usually occurs
via two .
BSSs
ESSs
None of the given

Question No'89
A property of a'sighal where it is being received by receiver after reflection from different
intermedidte objects (Building, iron polls, walls) is called

o Interference

o Error

o Multipath Propagation
Question No 90
medium is used in wireless LANs for transportation of data.

Copper pair cable
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Optical fiber cable
Coaxial cable
Air
Question No 91
In context of control signaling network, what does STP stand for

o Shielded twisted pair
o Signaling transmission point

o Signal transportation procedure

Question No 92
POP stands for

o Presentation of points
o Points of points

o Points of packets

Question No 93
What does LATA stand for

> Local Area Transmission Arena

» Local-Access Transit Acéess
» Local-Areas TransportvAreas

Question No 94

Unipolar encoding scheme 18,not supported over the medium having
» The capability ‘of handling DC component
» Low speed
» High specd

Question,No,95
The amplituderof a digital signal depends upon the to represent a bit.
P Phase
» Wavelength
» Bandwidth

Question No 96

Transmission Control Protocol is a(n) layer protocol
» Application
» Network
» Session
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Question No 97

In each station is allotted a time slot during which it can send data
> NDMA
> CDMA

» FDMA
Question No 98
In collisions are avoided by deferring transmission even if the channel is idle
» The Slotted Frame
» The Deployment Frame
» The Contention Window

Question No 99
In the context of Ethernet Implementations, maximum medium length'ef 20 Base-F was
meters.
» 500
» 1000

> 2000
» 150
Question No 100
Collisions in CSMA/CA are avoided through
» The Interframe Space
» The Contention Window
» Acknowledgments

The extra bits added withithe original data for error detection/correction are called
Process IDs
Redundant bits
Fault bits
Port Number
areqused to'exehange session management and control between connected devices.
» U-frames
P> “N=frames
» S-frames
P, I-frames
3. The message 1110 sent by source is received by a destination as 1011.Thisis __ types
of err.
» Hamming
» Single-Bit
» Uni-Bit
> Brust
4. In Block code we divide our message into blocks of K bits called as
» Password
» Code word

AL A A
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» Data words
» Cross words
5. DLC in Data Link Layer stand for
» Demand Link coordination
» Data Line Code
» Data Link Control
» Divide Line Communication
6. is responsible for governing node to node Communication.
» Data Link Layer
» Session Layer
P> Presentation Layer
» Application Layer
7. Go-Back-N protocol is one of the Layer protocol, which®is‘useditoeontrol the flow
of data during the transmission
» Presentation
» Network
» Data Link
» Physical
8. Error correction in more than the erro detection.
» Useless
» Informal
» Difficult
» Easy
9. Stop-and-Wait protocol is usedsfon,
» Flow control Only,
P Neither flow nog.error ceritrol
» Both flow and error control
10.  isnot a function of Data Link control
» Framing
» Efor Control
P, FlowrControl
» Modulation
11. Payload filed of the PPP frame is of variables Size and it can carry maximum Data up
to
P 10 Bytes
> 500 Bytes
» 100 Bytes
» 1500 Bytes
12. In Block Coding Scheme, number of Code word is always data wods.
» Equal to
P> same as
» Greater Then
P> Less then
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13. High-Level Data Link Control(HDLC) defines  types of frames to deal with the
transfer modes.
» Three
» Two
» Four
» Six
14. Congestion control is a feature of layer(S)
» Transport
» All Mentioned
» Network
» Data Link
15. Error detection and correction are the services provided by Layer.
» Physical Layer
» Application Layer
» Data Link Layer
P Session Layer
16. IN Linear Block codes,  of two valid code words creates,another valid code word.
» AND
» OR
» XOR
» NOR
17. Stop-and-Wait protocol is used for
» Bothe flow and error contrél
» Error control Only,
» Flow control Only,
» Nether flow ndmerror control
18. CHAP is an Authentication"ptrotocol, which uses process to authenticate user
information.
» Four way
» Three Way
. Two Way
P> “Eiveway
19. Dat@ link layer is divided into  sub Layer
P, Seven
» Two
» Five
» Three
20. If we need to correct a single error in an 8-bit data unit, we need to
consider possible error location.
> 16
> 2

>
>

8
4
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_____is not a function of Data Link Control.
» Framing
» Modulation
» Flow control
» Error control
22. The is the number of single elements sent per unit time.
> Slngle rate
» Period
» Bit rate
» Data rate
23. In ASK, both and remain constant.
» Amplitude, Frequency
» Amplitude, phase
» Frequency, Phase
» Amplitude, Samples
24. In an analog hierarchy to carry voice channels, a group can cancy
voice channels.

» 60
>N12
> 20
>, 10
25. Which of the following sublyer resolves the'contention for theshared media.
> MAC
> LLC
» Physical

» None of the giyen.
26. What is the period of a Sthe wave having frequency of 5 Hz?
> 0.2
> 0.1
» 0.5
> 0.3
27. In CRCGxthete 1s no error if the remainder at the receiver is

» Equal to the remainder at the sender
» Zero
P Nonzero
» The quotient at the sender
28. Analog To Analog Conversion Methods include
> AM, PM and FM
» AM, FSK and PM
» AM, PM and QAM
» None of the given
29. Signals travel through fiber optic cable are in the form of
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> Light
> Bits
» Electromagnetic
» Bytes
30. If the Hamming distance between sent and received code word is
, then it shows that received data is corrupted.

> #0
> =0
> £1
> =1
31. The flag in PPP is a byte that needs to be whenever it
appears in the data section of the frame.
» Duplicated
» Blocked
» Cleaned
» Escaped
32. is normally used where speed is priority in datdtransfer.

P Serial data transmission
» Hybrid data transmission
P Parallel data transmission
» Both parallel and serial data transmiSsion
33. Baud rate is greater than or equal to the'bit rate:
» True
> False
34, is an Authentication Pfotocel, Which is used by the PPPto authenticate
passwords.
» CHAP
> PAP
» LCP
> ICMP
35. In Pure ALOHA ,the»vulnerable time is the frame
transmission'time
P> “Same as
» Two times
P, Three times
P Four times
36. A broadcast signal is received by the orbiting satellites whichrebroadcasts_.
P to the resender
P to the sender
P to the atmosphere
P> none of the given

37. In TCP/IP protocol suite, the process of adding header at eachlayer on sending side
is known as
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38.

39.

40.

41.

42.

43.

44,

» Encapulation
» De-encapulation
» Packetizing
» Framing
By using system, change in the file contentsduring
file transmission can be avoided.
» Routing
» Flow Control
» Error Detection and Correction
» Congestion Control
Which of the following consist of just one redundant bit per dataunit?
» Two dimensional Parity check.
» CRC

» Simple Parity Check
» Checksum
If duration of noise is decreased during a transmission over neisy¢hannel, fixed data rate
of the channel will cause
number of bits being impacted by the noise.
» Constant
» More
» Less
» Zero
The extra bits added with the originakdata for errordetection/correction
are called
» Fault bits
» Port numbers
» Redundant bits
» Process IDs
Flow control is needed to prevent
P> Bit errors
» Overflow of the sender buffer
» Overflow of the receiver buffer
P “Collision between sender and receiver
The inversion of the level represents a 1 bit in encoding
> NRZ-1
» NRZ-L
> RZ
» Manchester
The term means that only one bit of a given data unit ischanged
from 1 to 0 or from O to 1.
» Packet Error
» Burst Error
» Single Bit Error
» Character Error
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45. A sine wave is defined by characteristics.
> 2
> 3
> 4
> 5
46. Quadrature Amplitude Modulation (QAM) is the combination of
and
» FSK, PSK
» PSK, FSK
> ASK, PSK
» ASK, FSK

47. If we need to correct a single error in an 8-bit data unit, we needto consider
possible error locations.

o
o AN

48. To calculate the data rate for noisy channel formula is
used.
» Shannon
» Nyquist

» Propagation
» Greedy
49. GO-BACK-N protocol is one of'the layer protocols, which
is used to control the flow of data during the transmission.
Physical
Network
Presentation
Data link
50. A__ modenmis tsed to connect two DTEs directly.
> 'NULL
= Cable
> DSD
» Nore of the given
51.(Time division multiplexing is used in systems.
P Analog
» Hybrid
> Digital
» Automated
52. In OSI model headers are added at layer

vVvyvyy

> 1,2,3 only
» 6,57 only
» 54,3 only
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> 6,5,4,3,2 only

53. Line Configuration refers to the way two or more devices attachto a

» Path

» Circuit

» Link

» Router
54. A sine wave is

P periodic and discrete

» aperiodic and discrete

» periodic and continuous

» aperiodic and continuous

55. The logical connection between the peer layers is ____connection.
» Physical
» Direct
» Indirect
» Tengible
56. What is the frequency of a sine wave if it completes on€ cyele in2 seconds?
> 0.5
P, 06
>, 0.3
> 0.2
57. In Synchronous TDM, Time slots are not,samesn number asinput devices.
» True
> False
58. category of coaxial,cable i$used for thin Ethernet.
» RG-58
» RG-59
» RG-1
» RG-47
59. Radio wave transmissien utilizes different types of
propagatien.
> Two
» “Thice
> Four
> Five
60. BSCysupports transmission using

flow control.

» Full-duplex, Stop and wait ARQ
» Half-duplex, Selective reject ARQ
» Full-duplex, Selective reject ARQ
» Half-duplex, Stop and wait ARQ

61. In selective-reject ARQ, only the specific damaged or lost frameis_.
> Retransmitted
» Forwarded
» Selected
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62.

63.

64.

65.

66.

67.

63s

69.

» Rejected
Error detection and correction are the services provided by
layer.
» Data link layer
» Application layer
» Physical layer
» Session layer
The__ generates the data and passes it along withany control information to a__ ¢
> DTE, DCE
» DCE, DTE
» DTE, DTE
» DCE, DCE

Analog refers to something that is continuous in
» Time
» Space
» Frequency
» None of the given
Time domain shows changes in
P time w.r.t signal amplitude
P signal amplitude w.r.t time
P> time
» All of the given
Mr. Asif while sitting in Lahore i talking with his friend in Dubaithrough Skype is an
example of .
» Local Area Netwotk
> Metropolitan Area Network
» Wide Area Network
» Home Based Network
Which level of the, TCPAP reference model routesdata/information
across a fietwork ehannel?
». Applicatien Layer

» Datalink Layer
» Transport Layer
» Network Layer

There are types of serial transmission.

e 3

e 4

o 2

e None of the given
Latency is made of components.

» Two
» Three
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» Four
> Five
70. Like 10 Base 5, 10 Base 2 is a topology LAN.
» Ring
» Mesh
» Star
> Bus
71. is the rate of change with respect to time.
a. Voltage
b. Time
c. Frequency
d. Amplitude
72. Two or more computers connected so that they can communicate withieaeh other and
share information is called a

> satellite
» protocol
» broadcast
» network

73. Which error detection method consists of ayparity bit for each unit aswell as an entire
data unit of parity bits?
» Checksum
» Cyclic Redundancy Check (CRC)
» Longitudinal Red Check (LRC)
» Vertical Redundancy*Check (VRC)
74. Central Hub in a Trec'is, an
> Active hub
» passive hub
75. Time domain plot shew changes in signal phase with respect to time.
> trilg
> false
76. 1$ an Authentication Protocol, which uses two-step processto
authenticate user information.
» CHAP
» LCP
> PAP
> ICMP
77. CHAP is an Authentication Protocol, which uses process to
authenticate user information.
» Two-way
» Three-way

» Four-way
» Five-way
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78. No matter whether the link is dedicated or broadcast, data link control
(DLC) layer provides services between
» Virtual LANs
» Two adjacent nodes
» Ethernet links
» Source and destination PCs
79. Encoding digital data into digital signals is called
Analog-to-Digital Conversion
Digital-to-Digital Conversion
Digital-to-Analog Conversion
None of the given
80. encoding is almost obsolete today
Bipolar
Unipolar
Polar
None of the given
81. The Internet is .
» software for sending e-mail around the world
P a government-owned agency that links,computers
» a global network of computers networks
P aspecialised form of local area network
82. PSK is susceptible to the noise degradation.
» True
> False
83. Low pass channel has bandwidth between two stations.
» Dedicated
» Shared
» Multiplexed
» Infinite
84. In ASK, Noise,usually affects the
> Amplitude
P Phase
> Sample
» Frequency
85 Theflag in PPP is a byte that needs to be whenever it
appears in the data section of the frame.
» Duplicated
» Blocked
» Cleaned
> Escaped
86. Which of the following is not a characteristic of a sine wave?
» Amplitude
> Segmentation
» Phase

vvyyvyy
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» Frequency
87. In statistical time division multiplexing, number of slots in frame areless than___.
» Output data rate
» Input lines
» Input frequency

» Multiplexed T lines
88. If a digital signal has "L" number of levels. is the numberof
bits required to represent each level.
Log L
LogBase2 L
L Square
Log(2*L)
89. is responsible for governing node to node comrhuni¢ation.
Application Layer
Session Layer
Data Link layer
Presentation Layer
90. The original Ethernet technology with the data rate of,10Mbps is
called ?
> Standard Ethernet
» Fast Ethernet
» Gigabit Ethernet
» 10 Gigabit Ethernet
91. What is the period of a Sine waye having frequency of 2 Hz?
> 0.2
> 0.1
> 0.5
> 03
92. In line disciplingraftér the data transmission, the sending system
finishes withsan
> EOT
PNEKT
> ENT
» ESP
93.( arewsed for Multi cas communication, such as radio and Television.
P Microwaves
» Radio Waves
» Light waves
» Infrared Waves

vvyyvy

vvyvyy




