CS610 Final Term

A e Relies on the hardware manufacturer to assign a unique physical
address to each network interface.

P Static addressing scheme (Page 34)

» Configurable addressing scheme

» Dynamic addressing scheme

» None of the given

An interface for thin Ethernet must have an connector, and must

enerate signals according to the specification.

» RJ-45,10Base T
» RJ-45, 10 Base 5
» BNC, 10 Base 2 (CS610 Reference Book, Page 21)
» BNC, 10 Base T
A system with redundant bridges might have a problem with in the
system.
» Loop
» Filters
» Spanning Trees
» All given choices
A Bridge can
» Filter a frame
» Forward a frame

P Extend a LAN
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» Do all (page)
is used for typical data applications (where the data rate may be

unknown and bursty) and allows use of whatever bandwidth is available at a
given time.

» Constant Bit Rate (CBR) service

» Variable Bit Rate (VBR) service

» Available Bit Rate (ABR) service (Page 71)

» None of the given

ATM assigns each VC a identifier that is divided two parts to

produce a hierarchy.
> 21-bit
> 22-bit
> 23-bit
» 24-bit (Page 67)
of TCP/IP layering model, corresponds to basic network hardware.
» Physical Layer(Page 84)
» Network Interface Layer
» Internet Layer
» Transport Layer
places the boundary between the second and third octets
» Class A

P Class B (Computer Networks and Internets, page235)
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» Class C

» Class D
UDP and TCP are both layer protocols

» Physical

» Data link

» Network

» Transport (Page 101)
Connection-oriented service, Point-to-point, Complete reliability, Full-duplex
communication, Stream interface, Reliable connection startup and Graceful
connection shutdown are the services provided by

> IP

» None of the given

» TCP (Page 123)

» UDP

protocols of TCP/IP layering model specify how to ensure reliable

transfer.

» Physical Layer

» Network Interface Layer

P Internet Layer

» Transport Layer (Page 84)

identifies which application program on receiving computer should

receive the data
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» Logical address

» Source port

» Destination Port (Computer Networks and Internets, page313)

» None of the given

identifies the application program that sent the data.

» Destination Port

» Source port (Computer Networks and Internets; page313)

» Logical address

» None of the given
Which of the following are interior routing protocols?

» RIP

» OSPF

» BGP

» RIP and OSPF
The Border Gateway Protocol (BGP) uses for all communication

» UDP

> TGP

» Both UDP and TCP

» None of the given

measures distance in network hops, where each network between

the source and destination counts as single hop.

» BGP
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» OSPF

» RIP (Page 138)

» None of the given
OSPFis basedon____

» Distance vector routing

P Link state routing (Page 140 )

» Path vector routing

» Distance vector routing and Link state routing

performs local multicast and uses IP-in-IP encapsulation to send

multicast datagrams from one site on the Internet to another.

P Distance Vector Multicast Routing/Protocol (DVMRP) (Page 144)

» Core Based Trees (CBT)

» Protocol Independent Multicast Sparse Mode (PIM-SM)

» Protocol Independent Multicast =~ Dense Mode (PIM-DM)
The length of time required to send a variable length packet is variable and does
not require a.complicated interrupt scheme to detect completion of
transmission.

» True

P False (Page 72)
NEXT HEADER field in the base header defines type of header and it appears at
end of fixed-size base header.

» True (Page 112)
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» False
Although message exchange can be used to bind addresses, sending a request
for each binding is hopelessly inefficient.

» True (Page 99)

» False
Address mask defines how many bits of address are in suffix.

» True

» False (Page 103)
A computer attached to a given network can only communicate with other
computers attached to the same network. Is this a problem with multiple
networks?

» True (Page 81)

» False
In the 1970s large organizations began to acquire multiple networks. Each
network in the organization formed island. Employees needed to choose a
computer appropriate for each task. So they needed multiple screens,
keyboards and computers.

> False

> True(Page 81)
The term self-identifying is used for Classful IP addresses because the class of
the address can be computed from the address

P itself (Page 87)
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» prefix

P suffix

» mask
In which method of Address Resolution Protocol the protocol address
independent of hardware address?
Were "T" stands for Table lookup, "C" for Closed-form Computation.and "D" for
Data Exchange?

> T,C

> D

> C

» T, D (Page 97)
Reconstruction of original datagram is called reassembly.

» True (Page 28)

» False
A computer needs a complete stack of protocols to run either a client or a
server.

» True (ComputerNetworks and Internets, page 344)

> False
TCP uses mechanism to control the flow of data.

» door

» window (Page 126)

» acknowledgment
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P retransmission
In Direct point to point communication adding the Nth computer requires___
new connections.
» None of the given
>N
» N-1 (Page 23)
» (N2 -N)/2
In -----------—- , hetwork occupies the smaller area like aroom a floor or a building
» LAN (Page 4)
» WAN
» MAN
» None of the given
The third field of the header consists of ------ bit Ethernet frame type.
> 48
> 32
» 16 (Page)
>3

The.maximum size of an Ethernet segment is

» 250 meters
» 500 meters (page)
» 700 meters

» None of the given
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The network with Throughput T and Delay D has a total --------------- bits in
transit at a time.

»>D+T

»D-T

» D X T (Computer Networks and Internets, page203)

»D/T

places the boundary between the first and second octets

P Class A (Computer Networks and Internets, pagé235)

» Class B

» Class C

» Class D
Router detects datagram --------- than network MTU and then it splits into pieces
and each piece is ---------- than outbound network MTU.

» Larger, smaller (Page 108)
» Larger, larger
» Smaller, larger
» Smaller, smaller
Connectionless service, Message-Oriented protocol, best-effort delivery service,

arbitrary interaction & operating system independent are the characteristics of

» TCP
» UDP (Page 120)
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> P

» None of the given
----------- provide Application to application communication it also called end to
end communication

> P

» TP (Page 119)

» RIP

» None of the given
A routing table contains

» The destination network ID

» The hop count to reach the network

» The router ID of the next hopg(Page 102)

P All of the given
Which of the following protocols allows the sender and receiver to enforce
polices.

» RIP

» OSPF

» BGP (Reference Book 347)

» RIP and OSPF

measures distance in network hops, where each network between

the source and destination counts as single hop.

» BGP
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» OSPF

» RIP (Page 138)

» Non of these

includes a 32-bits address mask with each address, which allows the

address to be classful, classless, or subnetted.

» RIP

» OSPF (Page 140)

» BGP

» None of the given
One repeater --------------- , two repeaters -------—-------- the maximum cable length
limitation.

» Double, triple (Page 49)

» Double, 4 time

» half, triple

» Double, half
ICMP message transport.is acted upon by getting ICMP encrypted in IP.

» True (Page 117)

> False
Like most application programs, a client and server use a transport protocol to
communicate.

» True (Page 146)

» False
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Mapping between a protocol address and a hardware address is called Address
Resolution.

» True (Page 93)

» False
Address mask defines how many bits of address are in suffix?

» True

» False (Page 103)
A single networking technology is best for all needs.

» True

» False (Page 81)
In the 1970s large organizations began to acquire multiple networks. Each
network in the organization formed island. Employees needed to choose a
computer appropriate for.each task. So they needed multiple screens,
keyboards and computers.

» False

» True (Page 81)rep
Router detects datagram--------- than network MTU

P Larger\(Page108) rep

» Smaller

» None of given

» Equal

Information can flow in either or both direction between
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» Clients
P Clients and servers (Computer Networks and Internets, page 344)
» Servers
» None of given
On of the design goals for unicast route propagation is
P consistency
P inconsistency
P stability (Computer Networks and Internets, page 344)
» dynamic addressing
IPV6 address consists of
» 32 Bits
» 64 Bits
» 128 Bits (Page 128)
» none of the given
UDP offers application programs a Message-Oriented Interface, applications can
depend on protocol to preserve data boundaries.
» Trde (Page 120)
> False
In case TCP; retransmission, acknowledgment from a computer on LAN are
expected to arrive within
P Seconds

» Micro seconds
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» Milliseconds
» Nanoseconds
Twice NAT is another variant of NAT. it is used with site that runs server. In this
process NAT box is connected to Domain Name.
» True (Page 131)
» False
A network uses a ------ arranges for computers to be connected in a closed loop.
» Star Topology
P Ring Topology (Page 25)
» Bus Topology
» None of the given

Protocol addresses are abstractions provided by

» hardware

» software (Page 93)

P operating system

P internet
In Directpoint to point communication adding the Nth computer requires----
new connections.

» None of the given

> N2

» N-1 (Page 23)

» (N2 -N)/2
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In Point-to-Point topology there are two topologies.
» Tree and Ring
P Star and Ring
» Star and Tree (Page 5)
» None of the given
In -—------——-- , hetwork occupies the smaller area like a room afloor or a building
» LAN (Page 4)
> WAN
» MAN
» None of the given
Hardware that calculates a CRC uses two simple components.
» AND unit and XOR unit
P Shift register and X@R unit (Page 20)
» Shift register and AND unit
» None of the given
CRC can detect more errors than a simple checksum.
> trde (Computer Networks and Internets, page 80)
> false
The Gigabit Ethernet hardware operates at a rate of --------
» 10 Mbps
» 100 Mbps
» 1000 Mbps (page)
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» None of the given
Formally named informally known as the twisted pair Ethernet or

TP Ethernet.
» 10 Base 2
» 10 Base 5
» 10 Base T (Page 43)
» None of the given

An interface for thin Ethernet must have an connector , and must

generate signals according to the specification.

» RJ-45,10Base T

» RJ-45, 10 Base 5

» BNC, 10 Base 2 ( cs610 referehcesbooksPage 201)

» BNC, 10 Base T
A system with redundant bridges might have a problem with in the
system.

» Loop

» Filters

» Spanning Trees

» All given choices

computes shortest paths in a graph by using weights on edges as a

measure of distance.

» Greedy algorithm
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P Distance vector algorithm

P Dijksta’s algorithm (Computer Networks and Internets, page 112)

» Non of the given
Basic LAN technologies such as Ethernet, Token Ring, and FDDlusea .

» Connectionless service paradigm (Computer Networks and Internets, page
112)

» Connection-oriented service paradigm

» Both Connectionless and Connection-oriented . service paradigm

» None of the given

protocols of TCP/IP layering model specify how to ensure reliable

transfer.

» Physical Layer

» Network Interface Layer

» Internet Layer

» Transport l@yer (Page 84)rep
An Internet Address (IP address) is a unique binary number
assignedto a host and used for all communication with host

> 48-bit

P 32-bit (Page 85)

» 24-bit

» None of the given
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The address identifies the physical network to which the computer
is attached, while the identifies an individual computer on that
network.

» prefix , suffix (Page 85)
P suffix , prefix

» suffix , suffix

» None of the given

places the boundary between the first and second octets

» Class A (Computer Networks and Internets; page 235)
» Class B
» Class C
» Class D

places the boundary between the third and fourth octets.

» Class A

» Class B

P Class G (ComputenNetworks and Internets, page 235)

» Class D

field of header indicates whether a datagram is a fragment or a

complete datagram.

» FLAGS

» FLAGMENT OFFSET

» IDENTIFICATION
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» None of the given
provides connectionless service.

» TCP

» UDP (Page 120)

> IP

» None of the given
UDP and TCP are both layer protocols

» Physical

» Data link

» Network

» Transport (Page 101) rep
Connection-oriented service, Point-to-point, Complete reliability, Full-duplex
communication, Stream interface, Reliable connection startup and Graceful
connection shutdown are the services provided by

> IP

» None.of the given

> TCP,(Page 123) rep

» UDP

protocols of TCP/IP layering model specify how to ensure reliable

transfer.

» Physical Layer

» Network Interface Layer
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» Internet Layer
» Transport Layer (Page 84) rep
identifies which application program on receiving computer should

receive the data

» Logical address

» Source port

P Destination Port (Computer Networks and Internéts, pagé313) rep

» None of the given

identifies the application programthat sent the data.

» DestinationPort

» Source port (Computer Networks anddnternets, page313) rep

» Logical address

» None of the given
The Border Gateway Protocol (BGP) uses for all communication

» UDP

» TCP

» Both UDP and TCP

» None of the given
Which of the following protocols allows the sender and receiver to enforce
polices.

» RIP

» OSPF

Page 20 of 35

For more papers, go to VVUInsider.com




CS610 Final Term

» BGP (Reference Book 347) rep
» RIP and OSPF

uses distance vector approach to define routing

» BGP
» OSPF
» RIP (Computer Networks and Internets, page332)
» None of the given
ICMP message transport is acted upon by getting ICMP encrypted in IP.
» True (Page 117)
> False

Protocol addresses are abstractions provided by

» hardware
» software (Page 93) rep
P operating system
P internet
These packets serve same purpose on as frames on
» Intranet, LAN
» Internet, WAN
» Intranet, WAN
» Internet, LAN (Page 101)
Address mask defines how many bits of address are in suffix?

» True
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» False (Page 103) rep
A single networking technology is best for all needs.

» True

» False (Page 81) rep
A computer attached to a given network can only communicate with other
computers attached to the same network. Is this a problem with multiple
networks?

» True (Page 81) rep

» False
The term self-identifying is used for Classful IP addresses because the class of
the address can be computed from the address

» itself (Page 87)

» prefix

P suffix

» mask
Find the class of the address.
10100111 11011011 10001011 01101111

> A

» B (Computer Networks and Internets, page 122)

> E

> C

Find the class of the address:
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11110011 10011011 11111011 00001111

> A

> C

» E (Computer Networks and Internets, page 122)

> B
In which method of Address Resolution Protocol the protocoladdress is
determined by hardware address?
Were "T" stands for Table lookup, "C" for Closed-form Computation and "D" for
Data Exchange?

> T

» D

» C (Page 97) rep

> T,C
Which method of Address Resolution Protocol requires hardware broadcast?
Were "T" stands for Table lookup, "C" for Closed-form Computation and "D" for
Data Exchange?

» D{Page 97)

>T

> C

» T,D

Which method of Address Resolution Protocol resolution with minimum delay?
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Were "T" stands for Table lookup, "C" for Closed-form Computation and "D" for
Data Exchange?

> T,D

> c

> T

» T, C(Page 97)
On of the design goals for unicast route propagation.is

» Consistency

P inconsistency

P stability (Computer Networks and Internets, page 344) rep

» dynamic addressing
Propagation multicast routing information differs dramatically from unicast
route propagation?

» True (Computer Networks and Internets, page 335)

» False
To save traffic, an EGP does not summerize routing information from the
autonomous system before passing it to another autonomous system.

» True

P False (Computer Networks and Internets, page 329)
In IPv6 the type of address used for collection of computers with same prefix.
Are known as

» Anycast
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» Unicast
» Multicast
» Non of the given (Page 114)
Special types of addresses in IPv6 used for multiple destinations; possibly not at
same site. Are known as
» Unicast
» Anycast
» Multicast (Page 114)
» Non of the given
UDP offers application programs a Message-Oriented Interface, applications can
depend on protocol to preserve data boundaries.
» True (Page 120) rep
» False
Reliability is the responsibility of the layer
» Network
» Datalink
» Transport (Rage 423)
» Application
TCP uses mechanism to control the flow of data.
» door
» window (Page 126) rep

» acknowledgment
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P retransmission
FDDI can transmits data at a rate of ----------

» 100 million bits per second (Page 31)

» 10 million bits per second

» 1000 million bits per second

» None of the given
Computer networks are often called -------------- because they use packet
technology.

> Ethernet

» Switch networks

» Packet networks (Computer Networks@nd Internets, page 73)

» None of the given
A network uses a ------ arranges for computers to be connected in a closed loop.

P Star Topology

» Ring Topol@gy.(Page 25) rep

» Bus Topology

» None of the given
An --—--—----—- method, the network hardware designers specify how type
information is included in the frame and the value use to identify various frame
types.

» Explicit frame type (Computer Networks and Internets, page 108)

» Ideal frame type
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» Implicit frame type
» None of the given

An interface for thin Ethernet must have an connector , and must

generate signals according to the specification.

» RJ-45,10Base T

» RJ-45, 10 Base 5

» BNC, 10 Base 2 (cs610 reference book Page 20%) rep

» BNC, 10 Base T
A Bridge forwards or filters a frame by comparing the information in its address
table to the frame’s

» Layer 2 source address

» Source node’s physical address

» Layer 2 destinationaddress

» Layer 3 destination address
Most WAN systems include a mechanism that can be used to eliminate the

common case of duplication routing is called

» Hierarchal address
» Default route’{Computer Networks and Internets, page 172)
» Shortest path
» None of the given
of TCP/IP layering model, corresponds to basic network hardware.

» Physical Layer (Page 84) rep
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» Network Interface Layer
» Internet Layer
» Transport Layer
protocols of TCP/IP layering model specify how to ensure reliable
transfer.
» Physical Layer
» Network Interface Layer
» Internet Layer
» Transport Layer (Page 84) rep
is called an end-to-end protocol because it provide a connection
directly from an application on one computer to an application on a remote
computer.
> IP
» UDP
» TCP (Comptter Networksand Internets, page 306)
» None.of the given

uses distance vector approach to define routing

» BGP
» OSPF
» RIP (Computer Networks and Internets, page332) rep

» None of the given
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is ideal in a situation where the group is small and all members are

attached to contiguous Local Area Networks.

» Flood-and —Prune (Page 143)

» Configuration-and -Tunneling

» Core-Based Discovery

» None of the given
Router that decrements TTL to __ sends ICMP time exceeded message, with
router’s address as source address

> 3

> 2

> 1

» 0 (Page 118)

Protocol addresses are abstractions provided by

» hardware

» software (Page 93) rep

P operating system

P internet
Although message exchange can be used to bind addresses, sending a request
for each binding is hopelessly inefficient.

» True (Page 99) rep

> False
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ARP is almost always used to bind a ___-bit IP address to a ___-bit Ethernet
address.

» 32,48 (Page 98)

> 24,32

> 32,64

> 32,128
In the 1970s large organizations began to acquire multiple networks. Each
network in the organization formed island. Employees needed to choose a
computer appropriate for each task. So they needed multiple screens,
keyboards and computers.

» False

» True (Page 81) rep
In which method of Address Resolution Protocol the protocol address is
determined by hardware address?
Were "T" stands for Table lookup, "C" for Closed-form Computation and "D" for
Data Exchange?

> T

» D

» C (Page 97) rep

> T,C
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The general form of an IP datagram is with a header followed by data. The
header contains information that controls where and how the datagram is to be
sent.

» True (Computer Networks and Internets, page 332)

» False
To save traffic, an EGP does not summarize routing information from the
autonomous system before passing it to another autonomous system.

» True

» False (Computer Networks and Internéts, page 329)
Which of the following is a correct representation of the IPv6?

» 105.220.136.100.255.255.255.255.0.0418.128.140.10.255.255 (Page 114)

» 105.220.136.100.255.255.255.256.0.018.128.140.10.255.255

» 105.220.136.100.255.255.255.255.0.0.18.128.140.10.255.255.256

» 105.220.136.100.255.255.255.255.0.0.18.128.140.10.255
The number of connections needed for N computer in direct point to point
communication is equal to:

» (N2-N)/2 (Page23)

> N(N-1)

> N2

» None of the given
When an application--------------- data, it makes a copy of the data available to all

other computers on the network.
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» Broadcasting

» Multicasting

» Unicasting

» None of the given
Ethernet uses a ------ bit static addressing scheme in which each device is
assigned a unique address by the manufacturer.

> 64

» 48 (Computer Networks and Internets, page 109)

> 32

> 8
A system with redundant bridges might have'a problem with in the
system.

» Loop (page)

» Filters

» Spanning Trees

» All given choices
The product of delay and throughput measures the ____ of data that can be
present on the network.

» Area

» Volume (Page 80) rep

» Length

» None of the given
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Connectionless service, Message-Oriented protocol, best effort delivery service,
arbitrary interaction and operating system independent are the characteristics

of

» TCP

» UDP (Page 110)

> IP

» None of the given
Connection-oriented service, Point-to-point, Complete reliability, Full-duplex
communication, Stream interface, Reliable connection startup and Graceful
connection shutdown are the services provided by

» None of the given

» TCP ( Page 123) rep

» UDP

> IP

Questions:

Differentiate between IP and transport protocol with the help of example.
Give the main advantage and disadvantage of RIP. (2 Marks)
Tel the first assignable IP address from a 128.140.80.24/20. (2 Marks)

How was the NAT implemented? (2 Marks)

AN Y A=

IS ATM including LAN and WAN network. If yes what kind of connection is
established? (2 Marks)

Page 33 of 35

For more papers, go to VVUInsider.com




CS610 Final Term

6. Is IP multicasting beneficial? Defend your answer with proper reason. (3
Marks)

7. Can the length of the segment be increased 500 meter by adding three
repeater one with each segment. It can be done or not. (3 Marks)

8. How an administrator can handle static and dynamic routing. (3 Marks)

9. IS TCP/IP suit including ARP. What kind of messages arein ARP. (3 Marks)

10.Traceroute continues to increment the Time To Live until the value is large
enough for the datagram to reach its final destination. What happens
when the TTL is sufficiently large for the datagram to reach its
destination? (3 Marks)

11.Describe characteristics of BGP. (5'Marks)

12.Describe IPV6 addressing notation. (5 Marks)

13.Have there is a technique for achieving reliability through TCP. (5 Marks)

14.1s there any technique for achieving reliability through TCP? (5 Marks)

15.Give reasons for which IPv4 need to be changed? (5 Marks)

16.In a star organization there are 120 systems connected in a network. Give
your comments about delay; delay should be smaller or larger. Give
reasons? (5 Marks)

17.How TCP provides reliability? (3 Marks)

18.How TCP and IP interact with each other? (3 Marks)

19.Describe four factors for network classification? (2 Marks)

20.What is ICMP and what type of errors internet layer can detect? (5 Marks)
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21.In which situation RIP support for default routers? (5 Marks)

22.Give Pros and Cons of static and Dynamic routing. (5 Marks)

23.How ICMP used to test different tools? (3 Marks)

24.How does host join and leave a group? (3 Marks)

25.When packet lost what is the procedure TCP adopt? (3 Marks)

26.In this subnet blocks 192.168.1.0/26 What is the range of assignable host
address? (3 Marks)

27.Write the difference between Explicit and implicit frame type. (3 Marks)

28.Give the concept of zero compression regarding IPV6. (2 Marks)

29.Which technique is used for insertion and deletion in routing table. (2
Marks)

30.Can multiple IP addresses assighed or not on different interfaces of a
router. (2 Marks)

31.In which process backward compatibility of 100-base- T is done? (2 Marks)

32.Does OSPF.only share information with an area or does it allow

communication between different areas? (2 Marks)
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